Problem Adding a Subdomain

The above are my DNS settings. http://agenix.io resolves the website but http://www.agenix does not.

I also can’t get wither to re-write to https://*

What does the blue i say when you hover over it?

It would probably be better to do a redirect for www:

As far as the HTTPS, have you enabled Always Use HTTPS and Automatic HTTPS Rewrites in the Crypto section?

I have our website hosted on IPFS at ZrRGn2KE1N6HXxe4jU1I_d4sVw1I4Q2SSHS_P3yNSoc.
A TXT Record has been add with the name _dnslink and the content of dnslink=/ipfs/QmZRidD5nYu2Z87o8F5ziqo7VgYAwoPxJq3a5aMgVLSENt we have also added a CNAME record with the name of @ and the value of cloudflare-ipfs.com Under the Crypto Tab In Edge certificates I can see there are two certs *.agenix.io, agenix.io lower down I can see Always use HTTPS is on and Lower still I can see that Automatic HTTPS Rewrites is on.

None of the rewriting is working and any request on the subdomain www is also not working
the only one that does work is https://agenix.io

I have tried to add a cname for www but it doesn’t resolve the same as the naked domain. The http to https re-writes are also still not working

@sdayman I cant thank you enough, we are a huge step forwards after I followed that tutorial.

The only thing left that I need some help with is how to redirect http://agenix.io/ to https://agenix.io/ while keeping the existing page rule.


1 Like

Simply enable “Always Use HTTPS” in the Crypto tab.

I just checked and it is turned on but no taking effect

Oh, I see… It’s because it’s handled by cloudflare-ipfs.com. Actually no clue, maybe @cloonan knows something or can dig something from the internal wiki?

1 Like

http://agenix.io/ loads without the cert. http://www.agenix.io/ loads as https://www.agenix.io/.

In my case the root redirects to www

At the moment http://agenix.io/ is not redirecting to https://agenix.io/

Yeah, sorry. The other way around. www redirects to root with HTTPS.

1 Like

Would enabling HSTS force all requests to https?

Technically yes, but it will need to be preloaded… It will take time and it’s hardly reversible. Maybe try contacting support as well.

Poor Liam on support has tried his best but I get the feeling he’s non technical, the ticket number is 1721731 if you want to read the thread internally

@bkawk, I’ve read the post I’m just not to sure which issues still remain.
What exact problems are you experiencing as of right now?

The boys above have been really helpful in getting us this far, big thanks to them, just this one last issue to solve with your help

Hi @bkawk,

Not 100% on this, but I would guess that your settings there are not taking effect as you can’t set the root domain to :orange: due to The orange to orange problem. I believe that you will probably have to take this up with support.

Perhaps @cloonan can take a look? :slight_smile:

1 Like

I woke up to an email from Michel (Senior Support Engineer) suggesting that an alternative approach would be to “try a new hash so the WWW subdomain gets added to the Cross CNAME removal.” Is anyone capable of translating this into actionable steps?