Private network inaccessible on warp macos

When connecting using ZeroTrust WARP on my Android, I can access devices on the defined private network. However, on my mac when doing the same thing, the same IP’s time out and show nothing.

Could you please visit while connected to WARP on your Mac and share the output?


This is the output of that when my Mac is connected via WARP.

uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/112.0.1722.48

and this is the same site on my Android phone via WARP

uag=Mozilla/5.0 (Linux; Android 10; K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Mobile Safari/537.36

I see that your Mac is connecting over HTTP/3, which uses UDP instead of TCP. Do you have UDP proxying enabled in your network settings?

I don’t have any proxy enabled in network settings.

On another note when my router uses the same local IP range as is configured in zero trust ( mac does not connect to the private devices (android doesn’t seem to mind this). However, when the router’s local IP range is different ( than the zero trust range ( macos allows me to connect. Could this be contributing to or caused by the HTTP/3 issue? Maybe there is some mac setting that routes subnet routes internally rather than allowing cloudflare to handle them or something? idk.

I meant in the Zero Trust network settings.

Oh I never enabled the firewall in zero trust.

If the proxy is not enabled in Zero Trust network settings, then connections will not be routed through the tunnel to your private network. I believe TCP proxy is enabled by default, but you have to manually enable UDP.

I enabled UDP under the proxy settings and it did not make any difference. I still believe it’s because of the local subnet tbh, because when I change my router settings to use a completely different ip address space than zero trust, it works. Even on my mac with HTTP/3.

For now, I simply moved the IP ranges for zero trust up by 65,536
So is now, this should prevent any IP overlap with the local routing tables when connecting (even though the local routing tables are not needed by me).

Thank you for the help Albert!

Hi @nasrj3
I have the same issue, can you please explain what you did to solve it?

Hey woodyard!

basically in the macbooks network routing table, the routers subnet takes priority over cloudflares subnet.

If my private network that proxies through cloudflare uses the IP of say, then cloudflare will add a routing table entry into my macbook’s network config.

However, if you connect to wifi and the wifi router also happens to use the subnet, then the macbook will have conflicting routing table entries and will prefer the wifi routers entries.

One solution is to simply change the private ip cloudflare proxies. you can make it 192.168, or or whatever you want.

the second solution (this is on the one i currently use) is to manually modify the macbooks network routing table to delete the wifi routers entries for and replace it with a more strict subnet. say What this means is that now the wifi router will handle all requests from IP address → and it will leave IP’s → for cloudflare to handle.

If you want cloudflare to cover the entire IP range for 10.0.0.* you can just delete the wifi routers entry and replace it with, which basically only routes the ip “” through the wifi router, the other 10.0.0.* ip’s will then be handled by cloudflare.

You also could of course write a script that does this automatically (as did we) but I cannot share that for privacy reasons. (google is your friend).

If you need more of an in depth explanation or even an ELI5, let me know, i’m happy to help :).

1 Like

Thank you for your explanation!
My setup is at home so a pretty simple setup with as the subnet and a docker instance running a tunnel that makes the subnet available to my devices even if I am not at home.
So I am not sure if I understand the first solution you mention, where I could just change the private ip Cloudflare proxies.
I just want the WARP client to handle “all” trafic so it is routed through CF and then back through the tunnel, even if I am at home. It works like a charm on Windows.
I guess I have to look at fiddling with the routing table on the mac, I am just not so confident in doing so, so if you happend to have some sort of anonymized version of your script, I would be happy to get some inspiration from it.
Thanks again for taking your time!

If I run ‘sudo route delete -net’ in a terminal window, it acts like I want it to. But after a restart, the route is back which breaks it again. So question is if it is possible to run this command automatically when the WARP client connects? Is that what you do?

I added to the exclude list under Settings->Warp Client->(profile)->Split tunnels and that also seemed to do the trick.

So now I have this routing table (like default) and it works and routes all trafic through CF when WARP client is connected:

Check the network interface through which the Cloudflare warp client is connected or tunnelled. In my case, when I run the command ifconfig, I get the below network interface.

My tunneling virtual network in this case is utun4.

bash $ ifconfig
utun4: flags=1234<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
	inet X.X.X.X --> Y.Y.Y.Y netmask 0xffffffff
	inet6 AAAA::BBBB:CCCC:DDDD:EEEE%utun4 prefixlen 64 scopeid 0x19
	nd6 options=123<PERFORMNUD,DAD>

Now, add the private network interface that you added in the private network tunnel address to use the cloudflare gateway interface.

sudo route add -interface utun4

This should tunnel your private network cloudflare tunnel to use the route through the cloudflare gateway.