Private dns on ANDROID 9 not working


#1

https://1.1.1.1/help#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiWWVzIiwicmVzb2x2ZXJJcC0yNjA2OjQ3MDA6NDcwMDo6MTAwMSI6IlllcyIsImRhdGFjZW50ZXJMb2NhdGlvbiI6IkJPTSIsImlzcE5hbWUiOiJHb29nbGUiLCJpc3BBc24iOiIxNTE2OSJ9
Please check the url above.
I have set the private dns using the instructions on cloud flare blog but still the 1.1.1.1/help doesn’t show.


#3

Seems you have a VPN active. Private DNS will at least not work with OpenVPN. I guess this counts for any active VPN connection, not only OpenVPN.

Try to get rid of any DNS server that’s being pushed through the tunnel. But i don’t know if it makes any difference.


#5

I am using adguard 24x7. And under it’s dns setting I have selected cloud flare.
Does it still make a difference in selecting private dns?