Previously active site no longer showing due to SSL issue

I have had my website (garyfahey.com) up and operational for over a year but seem to have recently had an SSL issue with the page now showing ERR_SSL_VERSION_OR_CIPHER_MISMATCH.

I am a complete novice with tech stuff but had tried to follow all the suggestions (I even purchased an advanced certificate in case it was an issue after Cloudflare ceased working with DigiCert - I just wanted to get my site up and then would work on the problem later).

My universal certificate had been showing 'pending validation (txt) for at least the 48 hours I had noticed it and the advanced certificate I purchased has shown the same for the last 24/36 hours. I have disabled the universal certificate in case that was causing an issue but am still unable to access my site.

I have made no other changes to my domain/hosting/dns etc to have had this issue in the first place.

Any help would be greatly appreciated.

Thank you,
Gary

Hi @GaryF have you tried to toggle the universal SSL from enabled to disabled?

That is step 2 in the quick fix ideas in the cipher mismatch CommunityTip

  • navigate to the SSL/TLS tab and temporarily disable Universal SSL at the bottom of the page.
  • Wait for a few minutes, then re-enable Universal SSL to trigger the re-issuance of your certificates.

Hi @cloonan, thank you for your response. I have disabled the universal certificate but had not re-enabled it as i thought that may have played up with the advanced certificate i purchased, but i will try to enable it again and see if that works.

1 Like

Perfect, thank you. When you disable universal ssl, it removes all old certifcates, when you re-enable it, new certificates are issued. If that does not work, I’ll grab a persuader and give it a nudge.

Many thanks @cloonan. I have just re-enabled the universal certificate and will report back the outcome after sufficient time.

I really do appreciate your time and assistance,

Gary

1 Like

Hi @cloonan, I am not sure how long a good wait time is but I have re-enabled the universal certificate about 25 minutes ago and it is showing pending validation (txt) which the edge one is also (and has been for 48 hours).

Appreciate any steer on the best courses of action next.

Regards,
Gary

1 Like

Let’s get the Customer Support team to lend a hand. Can you open an Account ticket and share your ticket number here? You can open an account ticket here, https://dash.cloudflare.com/?to=/:account/support

Hi @cloonan , thank you very much for helping with this. When I click on that link it doesn’t appear to let me open a ticket? It says free accounts can only open tickets for billing, account and registrar. I do have the $10 monthly advanced certificate but not sure if that equates to a paid account.

I did complete the drop down boxes for my issue but it lands me back at the articles I have already worked through.

My apologies for being a pain, I am just not sure where I am going wrong.

Cheers,
Gary

1 Like

I will kick off an Account ticket and you will receive a copy of it via email. Sorry for the issues.


Hi @GaryF I created 3074045 and you will have received a copy of the ticket. I will flag your post here for the attention of my colleagues in Support.

Thank you @cloonan I very much appreciate the support and help.

Gary

1 Like

Hi there,

Cloudflare support team has followed up on your ticket #3074045.
We can see your Universal SSL has been active now.

Best regards,

1 Like

Thank you @yuri1 . I very much appreciate it.

The problem, it seemed, was that I had 3 NS records in my DNS that were causing an issue with the validation process. These were historic entries and not needed and once I removed them I disabled the universal certificate and re-enabled it and the site was up in a short space of time.

Thank you very much to @cloonan also for your support and help. This tech neanderthal is very grateful.

Gary

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.