Previous SSL Cert still showing?

dash-dns
dash-crypto
#1

Hi All

I’ve set up Cloudflare on a fair number of Wordpress sites before but I’m struggling with this one and this particular scenario - can anyone give me a steer please?

Domain was hosted with a third party and had an SSL Certificate issued.

Migrated the Wordpress site to my hosting (using the all-in-one migration tool). Set up Cloudflare account and installed the CF Plugin in Wordpress, configured API etc.

Transferred hosting to me (change of IPS TAG, it’s a .co.uk). Changed nameserver to the cloudflare supplied ones.

Now it’s obviously pointing at the right pl;ace as I can see it’s my version (I made a quick text edit to confirm I was viewing the one on my new hosting).

It shows fine if you put http:// in the address. But there’s no autoredirect to https:// even though that’s set in the CF Plugin and dashboard.

And if you put https:// in you get the security warning about the certificate being invalid, click on more info and it’s showing the previous certificate (secure-secure.co.uk) rather than the Cloudflare one.

Any ideas on a) how to fix this and b) educate me as to why it’s happening. The Nameserver is changed to CF, the DNS looks ok to me and is pointing the A records at my hosting (which has no installed certificate) but for some reason, something is pointing browsers towards the old certificate…

(Migration & Nameserver changes were done about 24 hours ago)

Thanks in confusion!

#2

FYI, the site is this one: Breeze Guest HouseLiverpool

#3

They aren’t

[email protected]:~$ whois  breezeguesthouseliverpool.co.uk | grep nameserver
        ns.mainnameserver.com                                                 ns2.mainnameserver.com

Either you didn’t change them at your registrar, or propagation hast not finished yet. Setting NS RRs ist not enough, assuming that your host ist not a CF partner.

[email protected]:~$ dig +short ns breezeguesthouseliverpool.co.uk
trey.ns.cloudflare.com.
tina.ns.cloudflare.com.
#4

Precisely that. They are set but not with the registry/registry.

1 Like
#5

Thanks Guys, I’ll wait a bit for the nameserver updates to fully propagate & see how it goes.

#6

It is not a propagation issue, you need to set the nameservers at your registrar.

1 Like
#7

My lesson from this is to check the nameservers at Nominet themselves next time!

It looked like they’d been updated at my domain control panel - which is why I was thinking some weird propagation delay was at work - but when I re-updated them, Nominet WHOIS reflected that in seconds and it’s now working.

Panic over… :slight_smile:

1 Like
#8

Thank you both for your help. It was very much appreciated and valuable learning - never stop doing that!

closed #9

This topic was automatically closed after 31 days. New replies are no longer allowed.