Prestashop BackOffice kicks me out

Answer these questions to help the Community help you get started.

What is the domain name?
Have you searched for an answer?

Please share your search results url:

When you tested your domain, what were the results?
27/7/2023 11:00 am

Describe the issue you are having:
After turning the whole website to cloudflare, everything seemed fine , but when I tried to log in to the BO today , it wouldn’t let me browse products , orders pretty much everything,

I can see that it changes the token AdminDashboard&token=50b8aeed32751985187a5a008093aa1f to AdminLogin&token=7e4ea73616c47f00b75ea14cd33d2651 and vice versa, I have no clue what is the culprit or the setting I need to have, the Prestashop version it and php is 7.

What error message or number are you receiving?
No error message

What steps have you taken to resolve the issue?

  1. Clearing Cloudflare cache
    2.Cleared browser cache
  2. Tried incognito mode
    4.Tried other browser
    5)Set the cloudflare SSL setting to strict
    6)Purged prestashop cache from FTP
    7)Disabled CLoudflare and it seems to work for now but not completely it keeps kicking randomly
    Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. Just try to log in to the BO

Have you tried from another browser and/or incognito mode?

Make sure your webserver is rewriting IP addresses.

Saw that I will test it with the hosting company and let you know if that worked for me,

ngx_http_realip_module this is configured in our webserver and it fetches the origin IP from the client not from cloudflare in our logs. so any hints?

The site is currently not proxied, so if the issue occurs right now, Cloudflare won’t be involved in the first place.

Should it only occur when it is proxied, then it typically is mentioned IP issue. If you say you are rewriting the addresses, you can only check your code and why it logs you out.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.