Preload key requests through cloudflare

Hi,
I am trying to fix Preload key request on my site.

I am using asset cleanup plugin to preload local font files.
The preload works absolutely fine with no preload key request error on Google page speed when I turn off cloudflare proxy and remove page rules too, but it doesn’t work when cloudflare is on.

Can any one please guide me how do I fix this with cloudflare on.

Thanx in advance

I just add a <link> preload tag in the top section of my HTML for my font files.

How are you setting this Preload?

Asset cleanup

I tried that link to the head method from theme section itself, but doens’t help (it may work if I disable cloudflare, didn’t check it thought)

This doens’t work if cloudflare is enabled, how do I make it work please with cloudflare enabled.

Do you have Cloudflare dashboard set auto minify HTML enabled ? That could be rewriting your HTML?

Try disabling auto minify HTML at CF dashboard level and do the HTML minification at origin/wp plugin level instead

1 Like

no sir, its not enabled

Okay, I cleared css/js cache using asset cleanup menu and it seems to be gone now.

:grinning:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.