Posting to WordPress from ContentMX (content marketing service)

We’ve just started with Cloudflare, and one thing we’ve noticed already is that ContentMX no longer works.

ContentMX is a content marketing website, and it can automatically post to various channels (including a Wordpress blog).

How do I enable ContentMX to access our website now Cloudflare is enabled? Presumably it’s an exception to a rule?

Thanks,
Phil

If they give you specific IP addresses to whitelist, you mad add them to Cloudflare’s IP whitelist:

If that doesn’t unblock them, you should ask them what error they’re getting and then post back here with that.

Thanks Judge.

The error I see from ContentMX is as follows:-

We are unable to connect to your wordpress instance. The following errors have occured:

Error: Google reCAPTCHA verification failed. Do you have JavaScript enabled?

(https://XXXXXXXXXX/xmlrpc.php)

Error: Google reCAPTCHA verification failed. Do you have JavaScript enabled?

(https://XXXXXXXXXX/xmlrpc.php)

This worked fine before implementing Cloudflare.

Is there are log within Cloudflare where I can see what IP address(es) and/or domain(s) it’s trying to post from?

Thanks,
Phil

It’s triggering some captcha system, although not one of Cloudflare’s doing since CF no longer using ReCaptcha. Therefore CF is not the one blocking ContentMX.

On your host, try whitelisting Cloudflare IP ranges: https://cloudflare.com/ips/ - Since CF is a reverse proxy, it will look like requests are coming from CF’s IPs which might be blocked.

Thanks Judge… I’ll give that a go, and report back.

OK. So, for completeness if anyone else has a similar issue…

The error message when posting to WordPress from ContentMX is:-

"Unable to Complete - An Error has Occurred

Error: Google reCAPTCHA verification failed. Do you have JavaScript enabled?

"

I’ve now whitelisted the IP addresses, as per the link above, by editing the .htaccess file as follows:-

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] # added the following 05/05/2020 to enable ContentMX (Microsoft content manaagement thing to post to WordPress OK)

RewriteCond %{REMOTE_ADDR} !^173.245.48.0$
RewriteCond %{REMOTE_ADDR} !^103.21.244.0$
RewriteCond %{REMOTE_ADDR} !^103.22.200.0$
RewriteCond %{REMOTE_ADDR} !^103.31.4.0$
RewriteCond %{REMOTE_ADDR} !^141.101.64.0$
RewriteCond %{REMOTE_ADDR} !^108.162.192.0$
RewriteCond %{REMOTE_ADDR} !^190.93.240.0$
RewriteCond %{REMOTE_ADDR} !^188.114.96.0$
RewriteCond %{REMOTE_ADDR} !^197.234.240.0$
RewriteCond %{REMOTE_ADDR} !^198.41.128.0$
RewriteCond %{REMOTE_ADDR} !^162.158.0.0$
RewriteCond %{REMOTE_ADDR} !^104.16.0.0$
RewriteCond %{REMOTE_ADDR} !^172.64.0.0$
RewriteCond %{REMOTE_ADDR} !^131.0.72.0$

#RewriteRule ^(.*)$ - [R=403,L]

and the problem is still there.

This topic was automatically closed after 31 days. New replies are no longer allowed.