Postfix: connection timed out on route*

My postfix server is failing to send any email towards cloudflare with connection time out.

Nov 16 18:42:20 59e947dcac8b postfix/error[1143]: 416AF1001D9: to=<[email protected]>, relay=none, delay=1264, delays=1264/0.03/0/0.04, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to[]:25: Connection timed out)

This has been happening for months and I just realized. Netcat towards the server also does not work and I do not have any firewall in-place. What is the possible issue?

Where do you have your Postfix server (e.g. provider/ISP, or perhaps it’s IP address)?

Is it only as you quote, or have you literally tried all of the addresses (from both route1, route2 and route3), with the same result?

What if you run a traceroute to e.g., what exactly does it show?

I just verified that the issue is my ISP filtering all the traffic towards port 25 for IPv4. I will be switching to IPv6 which is not filtered at the moment…

1 Like

That has been the default for many (especially residential) ISP’s out there to filter port 25 in outbound direction for many years, however, in the recent years, several hosting providers have taken such decisions as well, apparently in an attempt to limit the amount of outbound spam happening from their networks.

Some (hosting providers) may be able open up for it after a support ticket though.

That said, I’m happy to hear that you’ve found out where exactly the issue was hiding!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.