Post/Article page is continuously reloading after setting up SSL


#1

Hi There, hope you are doing well.

I am testing the free version of cloudflare. I am facing some weird issues:

  1. After setting up SSL, my home and other pages are working fine but my post/article pages are either continuously reloading or showing my mobile version theme’s post pages on desktop and sometimes they are not loading at all under https:// (but if you check them with http:// they work fine). Example post URL: https://mbahunt.in/venkateshwara-open-university-distance-mba/.

  2. Wordpress login/admin not working under https:// its giving Error: “This site can’t be reached. The connection was reset.”

I am using below plugins:

CloudFlare Flexible SSL Plugin
Really Simple SSL plugin

Page rule setting:

I had kept the “Always use HTTPS” option off for wp-admin access. I am using a arvixe asp.net shared hosting account.

Please help if you are aware of these issues and had resolved them. Thanks in advance.


#2

Hey there. Using that link you provided, it looks like there is a redirect loop in place. I’m not familiar with the Really Simple SSL plugin, but it may possibly be causing the issue. Or the two plugins are conflicting with each other (Cloudflare Flexible SSL plugin is meant to fix redirect loops when using Flexible SSL mode).

I looked around and found this which you may have already seen
https://really-simple-ssl.com/knowledge-base/ssl-cloudflare-really-simple-ssl/
and also this
https://really-simple-ssl.com/knowledge-base/my-website-is-in-a-redirect-loop/

Have you tried disabling the Really Simple SSL plugin? If you are using Cloudflare Flexible SSL I don’t think that you need it…

Did you change your Wordpress URL to ‘https’ in wp-admin General Settings?


#3

Hi Andy thanks for your efforts. I had resolved the issue. The issue was caused by Rocket Loader Module. I had disabled it and everything is now working fine. It is in Beta at this stage, I think we need to wait until Cloudflare update it and launch it as Stable version. Once again many thanks. Have a nice day!