Possible Caching Pluging Conflict

Hello CloudFlare community.
I’m having problems about performance. A weeks ago I transferred my domain and host from GoDaddy to SiteGround. I activated SSL, CDN after I installed my WordPress website. I use Hello Theme and Elementor + Elementor Pro.
But I realized that when I design something or make a change in an existing page, my changes are not visible for days! Also website load speed was more than 6 seconds! I blamed SG Optimizer for that. I tried to use WP Fastest Cache instead of SG Optimizer.
When I first installed Fastest Cache, load speed went down to 2 seconds! And no problems at all with Elementor. It was perfect for me.
But after one hour, when I made a change in Elementor just to see if it works, Fastest Cache plugin started to behave like SG Optimizer. Now my webpage loads more than 4, most of the time 5 seconds. I started to suspect that there’s a conflict with CloudFlare when I saw this error in error log:
[15-Jan-2020 21:09:08 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/customer/www/pratikogretmen.com/public_html/wp-admin/includes/template.php:2424) in /home/customer/www/pratikogretmen.com/public_html/wp-content/plugins/cloudflare-page-cache/cloudflare-page-cache.php on line 58
[15-Jan-2020 21:55:24 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/customer/www/pratikogretmen.com/public_html/wp-admin/includes/template.php:2424) in /home/customer/www/pratikogretmen.com/public_html/wp-content/plugins/cloudflare-page-cache/cloudflare-page-cache.php on line 58

I also wonder if SSL sertificate causes this problem (I use it in Full Strict) because I’ve seen a few people on google talking about it. Or can it be permissions of some files in database?

Now I can describe my problem as this: When I use plugin caching, since there’s a problem, my website loads really slow. If I don’t use it, every test says that I need to optimize things like js, css etc. and it’s slow again.
I’m out of ideas and I need help.
Thanks for reading.

Hi,

In my experience, the PHP warnings you are seeing have no relation to Cloudflare. They happen all the time in WordPress sites due to different plugin conflicts, and you may want to run the Tools > Site Health feature available in the WP dashboard to further diagnose it, and perhaps install the Health Check plugin, which will add a troubleshooting feature to that Site Health panel.

When you install SG Optimizer, it adds two big chunks of code to your .htaccess file (or equivalent server configuration file). They are both good and useful, and they are NOT removed when you remove SG Optimizer plugin. There was a recent change in this plugin that sets the browser cache for HTML to 6 months! You may want to check your .htaccess file and search for a line that says:

ExpiresByType text/html "access plus 0 seconds"

If instead of 0 seconds you see 6 months, edit it back to 0 seconds, to avoid browser caching of HTML altogether, or to any other value you may think appropriate for your website, like "access plus 1 day". This may (only a suspicion) be what’s making your site take too long to show changes on your pages.

Your SSL set in Cloudflare to Strict mode should not cause any of your issues.

You’d need to review all the options your caching plugin offers, to make sure you are setting it appropriately for what you site needs. The plugin support forum may be a good place to ask for more help.

1 Like