Port 8080 problems

I have already a domain which is linked to Cloudflare.

I created a program, which I already uploaded to my server with the port 8080 and its HTTP (not HTTPS). How do I link it as a subdomain to Cloudflare? I tryed adding new record with type A and the IPv4 (without the port :8080) of my subdomain and it proxied but didn’t work, it’s not linking it, then I tryed to add the port to that but didn’t let me add it. the error that showed in red was “ipv4_address must match the following: /\s(25[0-5])2ANDMORENUMBERSLIKETHIS”

How I solve the problem? thank you

Are you saying that when you try to connect to http://sub.example.com:8080, it doesn’t work?

Yeah. when I try http://subdomain.domain.com:8080 its not working :frowning:

And if you set the DNS entry for the subdomain to :grey: (DNS-Only), does it work?

How I do that?

Click the :orange:

Oh ok, let me try that and I tell you back :smiley:

1 Like

Nope, when i try http://subdomain.domain.mx:8080 it sends me to https://subdomain.domain.mx:8080.

I changed the port of my app to 8443 and tryed https://subdomain.domain.mx:8443 but it throws this error: Error 525 Ray ID: 57e48f5cafbcb308 • 2020-04-03 17:37:52 UTC

SSL handshake failed

If you’re getting an error with a Ray ID, then that subdomain is still on Cloudflare.

But that does show one problem: Your zone (domain) here at Cloudflare is set for “Always Use HTTPS” in the SSL/TLS -> Edge Certificates section.

What should I do? Change the SSL for that subdomain?

For starters, turn Always Use HTTPS off.

Done and using port 8080 for the subdomain port.

Looks like it worked hehe. Now the problem is the https for the Domain. How do I activate it for domain.com?

Nevermind, looks like the domain is taking the SSL.

Thank you very much for your help

1 Like

You might consider a Page Rule to match example.com/* with a setting of Always Use HTTPS turned on.

Oh, I understand now hehe. Ok, thanks alot for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.