Polish with AWS cloudfront and S3

Hi,

I am trying to enable polish with my S3 images routed through cloudfront and a CNAME in cloudflare DNS.

I can see in the image response header that the image is served through cloudflare and the cache is working, but there is no polish header.

Is polish working with S3 + Cloudfront and a CNAME?
Here is a URL example:

Shows up for me

image

Hi Sandro
Thank you for your message.
I tried cleaning cache locally and on cloudflare but still I can’t see it.
Any idea why?

Typically this is a caching issue, either locally or on Cloudflare but if you said your purged all caches it should actually work.

Could it be because of cloudfront?

I wouldnt think so, because whatever might be cached on their side the image should still be processed by Cloudflare. Can you post a screenshot of your browser like mine? Which operating system are you using?

That was a MISS, which is not processed. Reload and post another screenshot.


Anyway I tried with another picture on my S3 and I can see the polish header.
But there is no size difference between the picture on my S3 and the picture delivered by cloudflare
Why?

In that case Cloudflare decided there is no point in running Polish.

So it works now?

Yes it is working.
But why is it nor reducing the size of the pics?
I am currently using another service named imagekit but I want to move to cloudflare. This imagekit service is divided image size by 4.
I can’t do it with polish?

https://testimage.aajapancars.com/KDH201-0134900-3.jpg

Please refer to https://support.cloudflare.com/hc/en-us/articles/360000607372 for that.

Thanks Sandro for your help :slight_smile:

This topic was automatically closed after 30 days. New replies are no longer allowed.