Polish not working (no headers)

Hello.
I’ve enabled Polish and purge cache, however It seems that polish is not working (Image is served as JPG, and there is no additional headers), even tho I am sending accept header with image/webp
What can be the reason for that?

Please use the search, that topic has been addressed quite often already. Polish only converts images if the WebP image is smaller than the original, which is not always the case.

Do you have a sample link?

https://public.wahedinvest.com/default/en-US/images/home/diversified.jpg

Afaik headers should be added always ( webp_bigger ) header

That is true, but Polish only works for hosts which are proxied through Cloudflare and yours isnt. It is a CNAME for a Cloudfront host. You need to enabled proxying by switching the record to :orange:.

2 Likes

Thanks you are right.

    https://wahedinvest.com/icons/icon-512x512.png

This is behind cloudlare, but still not polish header, is it because image was not cached yet? ( cf-cache-status: MISS)

Most likely, but your server seems to send caching directives which currently make caching on Cloudflare impossible, hence also Polish.

Oh, yes. Thanks for you help

This topic was automatically closed after 30 days. New replies are no longer allowed.