Polish not converting images to WebP

-Website is https://www.sfveincenter.com
-I have Polish “lossless” enabled in CF Pro subscription along with “WebP” checked.
-I’ve cleared cache
-I have a WP image plugin called “Short Pixel Optimizer” with WebP settings disabled so basic unaltered images should be cached to CF.
-In Chrome when i view images, they never show as WebP. When i look at the headers, i don’t see anything that says “status=webp_bigger” which i think would indicate that WebP does not need to be used. So I think images are not even being considered for conversion to WebP.

Any help is appreciated.

Being considered it seems, however Cloudflare doesnt believe it is “needed”.

image

If your JPG images are already well-optimized (compressed with a quality jpg processor), you will likely get a relatively low hit rate for webp conversions in polish lossless mode. I have inspected this for our own website.

You might consider trying to enable Polish “lossy” mode, in which case you will get a much higher webp conversion rate. I didn’t like the idea of “lossy”, but I discovered the visual impact is minimal, yet it yields massive cuts in file size.

1 Like

Thank you so much to both of you.
So it sounds like it’s working correctly which is great.
And i can try a different mode which may help speed.

Thanks again.

It looks all right to me. If you want to clarify why Cloudflare sends a “not_needed” status, you could open a support ticket.