Polish never work

I have purchased Polish service , but all images are not webp , I have used Polish for almost a year , they never become webp.

is it normal?

Can you provide us with the Domain, so we can inspect this?

Please notice: if you are testing from Safari/iOS/macOS:
most Apple devices do not support webp yet. Also the URL does not change, just the MimeType of the file. To know if its a webp you would have to inspect the header. Just saying in case you dont know already

And it also is just providing a webp file if CloudFlare could produce a webp with the given configurations that is smaller then the ooriginal file

1 Like

This ^

pls check it for me ,thank you very much.

I use mac , do you mean I can’t see they are webp because I use mac?

If you’re using Safari on a Mac that’s not running Big Sur, then you won’t get WebP. Otherwise, it is working.

1 Like

I just could find 3 (of 56) JPG files beeing served as WEBP.
One example:
WEBP JPG

Here Polish could reduce the size from:

16991kb => 11542kb by converting to WEBP.

ALL the other files (beside these 3) are indeed at least for me JPG files as they are on you origin server.
This means Polish could not improve filesize by converting to WEBP.
Have to admit I was also expecting more, but maybe your files are just already very very optimized.

1 Like

Some of the PNGs are converted to WebP.

1 Like

Yes have to correct:

PNGs (4/7):

JPGs (3/56):

@night119 have you set Polish settings to lossless or to lossy?

1 Like

thank you.

it works , but not all images right?

it looks like maybe I don’t need Polish . but Polish plan has firewall service , so I should forget webp.

thank you very much.

lossless

Depending on your setting.
Would you mind sharing the polish settings with us?
lossless or to lossy ?

I its lossy I’m dissapointed, if you had set it to lossless its acceptable and good value for the price, but not affecting too many pictures.

#sheet: stupid question as header shows: cf-bgj: imgq:100,h2pri

Please set it to lossy as it will most probebly not be visible to the eye that its not lossless. But then it will affect more pictures and you will profit from polish. If set to lossless it will not optimize a lot of pictures as WEBP in a lot of cases are even bigger if converted from an already optimized jpg.

Please set to “lossy” and we test again

I don’t know lossy will turn image to what , so I choose lossless.

I use Lossy. It still looks good enough for me.

1 Like

ok , I will try it now.

Congratulations, now it is like this:

48/59 JPGs now are webp! over 80% and no real visible notice :+1:

Also: ALL your pictures shrinked from 2.5MB to 1.9MB (24% smaller)

Before Lossy:
Before lossy

After Lossy:
lossy

1 Like

QQ20201205-020557

how you do that ? I see most are still jpg.

I use chrome in mac.

Magic :wink:

Please deactivate Cache and then reload:
PNG WEBP

Otherwise your browser takes the files from local cache and does not redownload.

ok, I see most are webp now.
hahaha
thank you very much.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.