Policies don't work to users linked with Cloudflare Teams through Cloudflare WARP


I am trying to connect my desktop and mobile phone Through Cloudflare to aply for them some policies about dns filtering.

To make that, I have got installed aplication in both and activated WARP, I have create the devices in dashboard and linked too. Also I have create a locations and linked with a policies to block pronography domains, nevertheless I can continue accessing to domains with adult content with both devices.

Why is not working?

Thanks in advance and sorry for my english.

Have you configured the DoH subdomain? That is what chooses which policy applies to the device.

1 Like

First of all, thanks for your answer.

Yes, DoH subdomain is configured and Auth Domain is linked with both devices.

What could I be doing wrong?

I was doing different things and doing over and over again and don’t work.

I have could check that, when I am surfing Internet with Google, those domain requested (for example “example.com”) are not registered by Gateway and just appear in Logs>Gateway such as “example.home” and it is allowed. :thinking:

Sorry, I was replying but I didn’t do it with “reply” option.

Please, I will be appreciated if you could check last answers and give me more suggestions.

Thanks in advance.

AlejandroD can you file in-app feedback via the Cloudflare WARP client and let me know the ID of the ticket you get back?

My feedback ticket ID is 4589.

Thanks for your answer Kkrum.

I just noticed the same issue on the iOS app, and was able to reproduce the issue on several devices with different accounts.

  1. In Settings > Advanced > Connection options > DNS settings, set the Gateway DoH subdomain value to a location’s DoH value (such as blahblah from blahblah.cloudflare-gateway.com)
  2. Location policies are enforced
  3. In Settings > Account, sign in with Cloudflare for Teams
  4. The Gateway DoH subdomain is changed to a GUID
  5. Location policies are no longer enforced
1 Like