Poland requests blocked mistakenly

Hello,

I recently noticed that all visitors from Poland do not get CSS/JS loaded. Upon further inspection, it turned out the POPs in Poland from my CDN provider (BunnyCDN) get blocked as any other visitor.

If you are in Poland or have a VPN with the capability to connect to Poland you can check by first seeing that https://simpliservers.com loads with no CSS and that https://cdn.simpliservers.com is blocked. Loading the website or CDN URL from any other country works.

I’ve tried whitelisting IPs, and checking firewalls, but it seems like I am missing a setting which is causing this behaviour. I don’t know what can I do apart from whitelisting.

If anyone has any idea what could be happening and tell me where should I look or what setting I need to be careful of, it would be greatly appreciated.

All the best and thanks in advance for any support, Matic

I’m not sure what this has to do with Cloudflare.

cdn.simpliservers.com points to simpliservers.b-cdn.net, which belongs to Bunny.

You’ll have to ask Bunny why it’s blocked.

1 Like

Well, Cloudflare is the one which blocks the page for both visitors and CDN. See attached:

Fair Point.

But, as I said, that hostname is hosted at Bunny CDN. Whatever is going on there is under Bunny’s control.

I’ve checked with Bunny, they informed me they have nothing to do with the block as they just issue a GET request which Cloudflare blocks (from Poland specifically). That’s the same behaviour I got.

I value your help a lot, however, unfortunately, it doesn’t lead to the solution as there is something else blocking Polish requests. I’ve temporarily redirected Poland CDN pulls to a different region which fixed it.

I still believe it’s Cloudflare blocking it.

No doubt it’s a Cloudflare page, but Cloudflare doesn’t inherently block any country or specific IPs by default. Cloudflare can’t give any insight or amend the security settings of anyone except to the website owner - who would need to verify that the domain is associated to their account.

You’ll need to log into http://dash.cloudflare.com, check the firewall activity log & see what rule caused it - if you don’t have the site in question under your Cloudflare account then you’d need to track down who is using Cloudflare for your website.

Ahhhh…now it’s beginning to make sense. Bunny is just returning the error page they got from Cloudflare. They should find a better way to handle that. If they ask for something, but get an error in return, they need to find a better way to convey that.

Since got a RayID for that request, this should be easy.

Thank you both very much for the input. Very oddly, If I reproduce the error and copy the ray ID, there is nothing in the firewall logs (https://dash.cloudflare.com//simpliservers.com/security?ray-id=::). Is that the correct place I should be looking in?

From App Preview Error- This web property is not accessible via this address:

I looked through the Community page and found your comment under a similar problem so I tried it and it worked. When Bot mode is disabled, the CDN fetches work normally. Even though I am not using apps, it works now. Perhaps it’s time to upgrade to paid plan.

Thank you again to both for your helpfulness :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.