Pointing my Heroku app to own domain


#1

Hey!

I want to point my dns target to my domain name, I’m supposed to add the dns target to cloudflare as cname, but on my dns I see the domain already mapped to another IP address. Am I supposed to edit that or just create a new cname for all this? I’ll really appreciate any help. Thanks.

Linda.


Error 525 handshake failed
#2

Can you post your domain and a screenshot of your DNS settings on Cloudflare?


#3

Hey Sandro,

Domain is sororitie.com


#4

All right, setup looks okay. Which entry would you like to point where?


#6

I would generally avoid wildcards. Am I right to assume you want your naked domain and your www record to point to terrestrial-triceratops-28ld43h1xc8plrz17u3uk1qy.herokudns.com? If so you should just create to CNAMEs for www and @ and point them to the address. Note that the @ record will be marked as flattened as these can typically not be CNAMEs and will be turned on-the-fly to A records with the applicable IP address.


#7

I’ve just tried to do that and this is what I get:

I changed the @ to sororitie.com too


#8

You already have an A record. You will need to remove that first as the message indicates.


#9

Thank you for being so patient with me Sandro.

So, should I remove the other A records? Am I on the right track now?


#10

Does your naked domain go to the right place now?

As for the other A records, I cant tell. If you dont need them you can remove them. If you do, obviously not :slight_smile:


#11

Unfortunately, not yet. I keep on getting this error.


#12

That is presumably because of your SSL mode which should be one of the "Full"s if you want to use HTTPS. Also, check that your origin is properly configured.


#13

I really don’t understand what that means, sorry, can you please guide me through that?


#14

Post a screenshot of your Crypto section on Cloudflare.


#15


#16

Set that Flexible to Full strict and check how it goes. Just make sure you have a proper and valid certificate on your server.


#17

It worked, I’m so excited I have a different error, lol, means we are moving. Any ideas now? Do I need to change anything on my domain?


#18

As I mentioned before you need to make sure you have a proper certificate on your server. If you have a certificate but it is not valid you could downgrade to just “Full” but “strict” is certainly preferable from a security point of view.


#19

Downgrading does nothing yet, should I contact my domain provider to help me generate an ssl cert?


#20

Whats the host you are trying to point to? The screenshot shows a different value from what you posted earlier.


#21

I’m trying to point my heroku domain to my custom domain.

sororitie.com

Am I answering this well? Sorry. I’ve run out of replies.