Point domain to server behind Cloudflare without adding domain to cloudflare

I am trying to point a domain from a registrar to my website/server which uses cPanel (but is also behind Cloudflare) without adding the domain itself to Cloudflare.

But I keep getting the error saying the domain is not pointed such as:

Error: This domain points to an IP address that does not use the DNS servers associated with this server. Transfer the domain to this server’s nameservers at the domain’s registrar or update your system to recognize the current DNS servers. To do this, use WHM’s Configure Remote Service IPs interface.

I have tried pointing the domain A record to the server,


I have also tried setting custom nameservers to the same as the servers, and also tried setting personal DNS server to the server too.

But I did notice if I manually add the domain to Cloudflare it works.

I do not want to do this though as I wish to support other people pointing their domains to my server automatically without adding the domain to Cloudflare (as they may not want to use it).

Is this even possible? What am I doing wrong?


Cloudflare for SaaS Providers
Cloudflare for SaaS · Cloudflare for Platforms docs

Based on the phrasing, I would have some kind of scepticism, whether it would be possible for you to get that one away, while still using Cloudflare, … with Proxied (:orange:) records.

1 Like

Where are you getting that error?

um, I’m confused by that :point_up_2: line. What domain X do you want to point to what domain Y?

also confused by that :point_up: line

Why can’t they just forward requests from their server to your domain?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.