Point DNS to new registrar and host

I am moving my site from host1 to host2. Site is moved and working with api issues etc, since it’s on another url.

mysite.com is transferred to host2 now

Name servers are set to cloudflare 1 & 2 with new host
Old host is back at host1servera and host1serverb

mysite.com is still loading the old site.

Host2 says I need to update my Cloudflare DNS and point it at my host2 IP.

When I go to DNS app i’m lost … I have tons of cache info, a DNSsec button and I donno what.

So:
Do I wait 48 hours for succes
or Do I enter new DNS and where exactly?

It sounds like you just need to update the IP addresses for your site:

Thx sday

Your right and I did alter the IP in DNS and also force changed url in my theme functions.php

Its a WP site

All URLs look good now, posts, products

But not static pages. They still jump to stupid.temp.domain.com

What is wrong?

You might have to re-save your Permalinks structure in WordPress Settings. Hopefully that updates all links in your database.

Resave perma

How is that done?

Yes all permalinks are switched to

mysite.stupid.url/anything

How can redo this. I tried the save button permalink but it is not fixed for static links across the site

No one can really help you untill we know how the “static sites” are implemented, some “developers” code them really statically in the db without using the WP_HOME or WP_SITEURL or any other relativ path.
I’ve seen a lot of ‘things’ when it comes to WP and most of it was not really good as the best reason to use WP is because its cheap.
That said:
Could you provide usable datas? Like your Domain and one example page which is not working?

Also:
Why did you change the IP? Becasue you changed the server or the hosting environment? Maybe you are now on another Server?

If so: the chance of you made a mistake at the migration is very very high.
If not pls try the Plugin Better Search Replace to replace the needed strings in the DB. But be carefull and Backup first!

Have you also changed the DB-Credentials in your wp-config.php?? Cuz if not its still pointing to the old DB with the old Domain etc.

Also: this problem is not related to CloudFlare. Pls keep that in mind.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.