Podcast Disappeared Due to Cloudflare Settings

Per sitegound the issue is related to the Cloudflare service which you have active for your domain. If you would like to exclude that page from within the caching mechanism that Cloudflare provides, you can do so as per their official documentation:

My podcast - is no longer pulling up. This has affected itunes and other services.

Rules not working.

Is there any humans that can help me here?

Can you provide any more detailed information? What rules are you referring to? What exactly are you trying to do and what isn’t working? What’s being cached and shouldn’t be? Can you share any URLs or examples?


sure, thanks for the reply!!! My podcast disappeared due to something related to caching. mtnweeklydotcom/feed/podcast

SiteGround my host told me this was a caching issue with Cloudflare and that the podcast feed page needs to have a rule to exclude that page from within the caching mechanism that Cloudflare provides.

I added the rule and nothing is working. My host was able to bypass cloudflare and get the feed to pull up fine. prnt.sc/IhvKRKbO-4ot

I have tried: myurl/feed/podcast/
Cache Level: Bypass

Didn’t work.

I have tried:
Browser Cache TTL: a year

Still no luck. Sort of bummed to not have any support to contact here without paying $200 a month?

Looks to be working now. Not sure if it just took 12 hrs for rule to take effect or what?

Glad that it started working for you.

It is possible that you had a TTL on your cache which caused the delay. In the future when making caching changes it is recommended to Purge the Cache after making changes to prevent this.