Pls help me fix “too many redirects” error

I’m struggling to get my site completely set up - I hope you can help.

I have a primary WordPress site at that delivers a multisite instance at

In the site settings (you won’t be able to access it - but at uk/wp-admin/network/site-info.php?id=3 (that’s the site id of

If I change the siteurl and homepage settings to https rather than http, then I am unable to access the Dashboard at because I get a “too many redirects” error.

But if I leave it as http:// (no “s”) then I can access the dashboard, but I am unable to save or publish any pages or posts.

I am aiming for all pages to be delivered over https

Is there anything you need to know to help me sort this?


The best place to start is by clicking the automatically linked text of the error message that you posted.

It is also best to make sure your site is working properly over HTTPS before your enable the Cloudflare proxy.

Thanks The magic auto linking page helped (I’m sure I’d seen that before but couldn’t find it this time) Changing SSL settings from flexible to full resolved the issue :slight_smile:


Make sure it’s Full Strict, otherwise it is still insecure.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.