Please wait while your request is being verified

I have 2 websites using Cloudflare.

Right now both websites get stuck at a blank page with a single phrase: “Please wait while your request is being verified…

After a long time they both get redirected to a URL with the following pattern:[8-digit number]

In place of there is of course each websites respective address.

Is this a Cloudflare issue or not?

1 Like

That looks like it’s a hosting problem. I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

It looks like a hosting issue problem to me too. The thing is that when I do a reverse IP lookup and try to access other sites on the same server (I use shared hosting) I can access them without issue.

Maybe after all there is a specific problem with my account.

No way! I used “Pause Cloudflare on Site” and my websites load immediately!!!
It’s the second time Cloudflare causes me problems:Significant delay in website loading time with Cloudflare and I can’t figure out the exact cause.

Hold on…is this the standard JS Challenge screen? A screenshot would help.

Unfortunately, I don’t get the page any more. It’s not the standard Cloudflare page you show in the screenshot. It was a page with the phrase I wrote in the center of the screen and I suspect that it came from the origin server.

The thing is that again I get these 100 seconds delays when I have my pages tested with:

They go away when I disable Cloudflare.

Here you go. I unpaused Cloudflare and we go now for round 2 of problems!

The error appeared again and then I get a 404 redirected to[random 8-digit number]

Does your host recognize that message? It’s possible they’re rate limiting requests because they haven’t added the addresses from IP Ranges to their Allow list.

I’m not sure, I haven’t heard from them yet. They use railgun though which I have active.

1 Like

Is there a way to troubleshoot where the delay happens, between Cloudflare and the end user or between Cloudflare and the origin server?

OK. I contacted the hosting provider (x10hosting) and they claim that the issue is not related to them.
Any idea how I can troubleshoot Cloudflare’s end or find out where the issue lies if not with Cloudflare?

I found something!

Disabling Railgun makes the delay go away. The sites load fine. I’m still not sure for the origin of the message I posted.

1 Like

It’s possible that a Railgun message, but I’ve never seen it before. I’m glad that’s sorted out. It could be that your host’s Railgun configuration is no longer valid.

The page is probably unrelated with the delay issue. The host provider did not recognize it as a page on their server. Maybe that’s a Cloudflare page after all?
I now have Railgun disabled but I still get the specific (z0f76a1d14fd21a8fb5fd0d03e0fdc3d3cedae52f?wsidchk=[8-digit random mumber]) page with a 302 redirection to the root.

The page is probably not related with Railgun as it still appears when Railgun is deactivated. But with Railgun deactivated these 100 seconds delays have disappeared. So definitely activating Railgun causes a massive slow down and makes the load time very big.

When I check Cloudflare’s dashboard I see the Railgun State for my hosting provider as Active.

I’m not sure if there is a configuration issue related to Railgun with the hosting provider or Cloudflare or maybe a bug with Railgun’s code itself, but definitely something’s going wrong with it and it started about a month ago. Till then I always had Railgun enabled with no issues.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Please see my reply to another topic on this issue: