Please Help


#1

SMTP error from remote mail server after MAIL FROM:<[redacted by Cloudflare Support]@cairojazzclub.com> SIZE=3788:
550 5.1.0 74.50.21.131 is not allowed to send from <cairojazzclub.com> per it’s SPF Record. Please inspect your SPF settings, and try again. IB508 http://x.co/srbounce


#2

Your SPF record indicates which servers can send your behalf and any other server attempting to send should be considered a hard fail.

dig cairojazzclub.com txt +short
“v=spf1 include:spf.mail01.mtsvc.net -all”

The included SPF record is:
“v=spf1 include:spfnb.mail01.mtsvc.net include:spfnb1.mail01.mtsvc.net include:secureserver.net ~all”

The IP address listed in the error message resolves to “ms017lv.lunarservers.com” which is not on the list of allowed server to send mail on behalf of your domain. You could simply change the -all in your SPF TXT record to ~all to be a soft fail instead of a hard fail or otherwise update your SPF record to include the proper set of hosts authorized to send on behalf of your domain.


#3

Thank you so much
Appreciated J


#4

Sorry one more thing I’m not a tech guy so can you please guide me.
Thank you


#5

Since you already have a TXT record for your SPF settings, you’ll want to go to the DNS tab and edit the existing record.

Above is a screenshot from my personal test domain. If I wanted to be more liberal in what servers I allow to send on my behalf I could simply click on the section that begins “v=spf1” and change the -all to ~all. Here’s a link some documentation on what the values mean and examples.

http://www.openspf.org/SPF_Record_Syntax