Please help with email not working normal

I have configured as follows and get the following error

Captura3

also when configuring it with php I have the following error

Connection could not be established with host mail.menita.com.mx :stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed

You appear to have an Origin certificate installed. Thats good, however only works in a proxied context, unless you specifically trust its root certificate.

There are four options

  1. Connect to the proxies, instead of directly.
  2. Configure a publicly valid certificate on your server, instead of the Origin certificate.
  3. Configure your client to trust the Origin’s root certificate.
  4. Configure your client to skip the certificate validation.
1 Like

Thank you very much for answering.

How do I set the first option? { 1. Connect to the proxies, instead of directly.}

You are currently connecting to your “mail” record, right? You could either switch that to :orange: but that might break your mail configuration, otherwise simply connect to one of the proxied records instead (e.g. www).

1 Like

Can you give me an example please.
I leave you some capture of other configurations.

Is that screenshot from before from your mail client?

In that case you cant go the proxied way. Only options 2 to 4 will be available in this case or you disable the secure connection in your mail client altogether.

1 Like

I get it
How do I configure option 2
(Configure a publicly valid certificate on your server, instead of the Origin certificate.)

You simply get any publicly trusted certificate and configure that instead on your mail server.

1 Like

Do you have any tutorial links to do it?

I would recommend to use a search engine for details. We wouldnt be in Cloudflare territory here any more :slight_smile:

1 Like

I appreciate the help

Thanks a lot