Please Help! something wrong with Rate Limiting

After I changed my site to Cloudflare, the LCP of my 1389 pages increased to 8.6s.
So I try to run Pagespeed Insights, it can not show the result, and the Firewall data showed several hundreds of the following events during running Pagespeed Insights.
I don’t know what’s wrong with it, I’ve never open the Rate limiting rules, and my Security Level is high.
Please help if you know how to fix it.

Have you created any Cloudflare Workers script?

No, I even don’t know what’s this section means :sweat_smile:

Ok, this confirms that you don’t have any Workers script configured for your website.

How about Cloudflare Apps? Did you install anything from there?

No apps, also no Zaraz


I just turned off “Robot Battle Mode” and Pagespeed Insights worked again.
So I have to turn off the “robot battle mode”, wondering if there is a way to keep both of them working.

Not sure how your “robot battle mode” has any relationship with rate limiting (I assume you are referring to Bot Fight Mode), but glad that you fixed it.

Almost impossible due to the low customization ability of Bot Fight Mode.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.