Please ensure you are providing the root domain and not any subdomains (e.g., example.com, not subdomain.example.com)

Hi. This is my first post here.

I’m trying to make my website have a free SSL. I’ve been following step by step tutorials about it but I’m stuck at “please ensure you are providing the root domain and not any subdomains (e.g., example.com, not subdomain.example.com)” when I’m adding my site. The website is http://market.smartfac.asia/. Typing market.smartfac.asia does not work.

Any solution?

I am afraid Cloudflare cannot give you free SSL.
A free SSL can be generated using either tools like cPanel AutoSSL or a Let’s Encrypt (acme, certbot …) at your host/origin.

See here for help regarding how to obtaion a free SSL certificate:

There is an option to use Cloudflare CA origin certificate as described here:

Moreover, there is also an option to buy an SSL certificate if you do not have one from either Cloudflare or someone else like Namecheap or other SSL sellers:

Maybe you mean on Universal SSL which is generated and using Flexible SSL option which is not recommend (see below link)?

Your Website http://market.smartfac.asia/ is currently not pointed to a Cloudflare nameservers.

May we know what tutorial have you followed?
When adding a Website/domain to your Cloudflare account, could you please try as you should write in the input field smartfac.asia instead of market.smartfac.asia.

Here is a great one to start with:

In short, if you want to use Cloudflare, you would firstly need to create a Cloudflare account, then change your nameservers for your domain at your domain registar, then if needed check and setup the DNS records at Cloudflare dashboard (add @, www and sub-domain like market for your domain) and check for the SSL options.

If you have successfully added your Website to your Cloudflare account and changed the nameservers for your domain at your domain registar, in case if the records are missing at the “DNS tab”, here is a great article about how to add them:

May I ask have you had an SSL certificate already installed at your host/origin or was you Website (sub-domain) working on HTTP or HTTPS when visiting from your Web browser?

  • http://market.smartfac.asia/ currently does not resolve over HTTPS, meaning it does not have an SSL certificate (cannot establish an HTTPS connection)

Fristly, try it like this:

Screenshot_2021-03-08 Account Cloudflare - Web Performance Security

Hi. Thank you for the reply.

  1. May we know what tutorial have you followed?
    I was following this tutorial: How to Get a Free SSL for your WordPress Website - YouTube

  2. When adding a Website/domain to your Cloudflare account, could you please try as you should write in the input field smartfac.asia instead of market.smartfac.asia .
    I was about to type smartfac.asia, but when I typed that in the google URL, I will get a Privay Error message that says:
    Attackers might be trying to steal your information from smartfac.asia (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_DATE_INVALID
Is smartfac.asia belongs to my website?

Your SSL certificate expiried on 14.11.2020. - SEC_ERROR_EXPIRED_CERTIFICATE.

Your Website is available via HTTP, in the meanwhile it is over HTTPS but with an expiried SSL certificate.

Can you try to renew it first?

Moreover, have you successfully added your domain to Cloudflare or not? (without this step you cannot have sub.yourdomain.com working with Cloudflare services)
As far as I have checked it still does not point to Cloudflare nameservers.

This topic was automatically closed after 31 days. New replies are no longer allowed.