Please check your device's clock alert begun to appear on mobile devices

Hello, this begun to happen today.
Te site it is always running in “under attack mode”, today besides the usual CF alert message (Checking your browser before accessing…) a new one appeared: “Please check your device clock, it seems to be set to the wrong date and time”, but the alert does not go away, the site does not open. This seems to affect only mobiles, particularly Android devices.
Any suggestions?
Thank you!

The site reguarly is set in “under attack mode”, as of today some devices are showing an alert that says: Please check your devices clock. It seems to be set to the wrong date or time, and the website wont open, just stays there on that alert.
The site didnt have changes from yesterday to today, what could be wrong?
Thank you!

Ps. If I turn off under attack mode those mobiles phones can access.

Did you? What were the results?

Based on the details you provided, the issue seems to be completely unrelated to Cloudflare and as indicated is related to the time settings on the affected mobile devices. To resolve it, you need to ensure the device’s date and time are set correctly:

  1. Open the “Settings” app on your Android device.
  2. Tap on “System”, then “Date & time”.
  3. Ensure “Automatic date & time” and “Automatic time zone” options are turned on.

If this does not resolve the issue, you might need to clear your browser cache or try accessing the website with a different browser on your mobile device.

Thank you @cloonan for your reply, the strange thing that that alert appeared as of today, on a lot of devices (the site is a newspaper), readers begun contacting the Newspaper reporting the error.
The android device that I have doesn’t show the alert, I went to the system settings you mention and they were set on automatic (date & time and time zone), disabled both of them, reloaded the site but didnt showed that alert.

1 Like

UPDATE: We tried with one of the phones that shows the alert, the switch for date & time was off, on that phone it is off because if ON the current time shows one hour more (14:56 instead of 13:56), any way, they put the switch to ON and it loaded the website.
The thing is that switch was off yesterday and before, Im guessing is the same scenario for a lot of devices.

If I disable the “under attack mode” and create a rule to challenge the traffic, it also displays the same alert. Seems that the validation some how is checking the devices current time zone.
But, if this rule I´ve created shows the alert, seems that all the rules I have alredy created will suffer from the same notification.

Warning icon Please check your device’s clock. It seems to be set to the wrong date or time.
any help to assist getting through this problem?
my time zone is set correctly UTC-04.00 Atlantic Time.
cannot proceed to web site due to this warning message.

We have lots of customers complaining about this as well… Seems to be some new issue with cloudflare’s managed challenge. I’m curious to see a response from CF.

We have dozens of customers complaining about this yesterday and today as well. Seems like CF made some changes to their managed challenge system which is now blocking legitimate traffic.

Since cloudflare requires you to be a paying member to directly contact then ibfeel this problem will never be resolved. Typical ignorance and incompetence from Cloudflare.

We are looking into this issue and should have a fix shortly.

5 Likes

Will see

That’s what I thought, lets hope they fix it.
Thank you for sharing.

1 Like

In my case the custom page doesn’t have the meta tags mentioned on the incident report.

2 Likes

Our page doesn’t have those meta tags listed in this issue either. Our challenge page also hasn’t changed in months. This is 100% clearly a change that CF implemented in the past couple days that appears to be doing an extra clock check, and it’s malfunctioning (or being too strict).

2 Likes

i just need to resolve a problem with the Cloudflare service . I dont have anything to do with Cloudflare so my statement is correct

In some cases, when users sync their clock in their OS it solves the problem. Their clock might only be a few seconds off but it seems to be triggering this challenge error. Feels like somebody set a sensitivity setting a little too aggressive.

It looks like CF may be aware of an issue, per this thread: Warning icon Please check your device's clock. It seems to be set to the wrong date or time

1 Like

yep after a poor review on google because the do not allow non paying members to submit a written complaint or ticket to resolve a problem, Ignorance and incompetence of Cloudflare

@trooper9698 that is not correct. Customers on any plan type can create registrar, billing, and account tickets https://dash.cloudflare.com/?to=/:account/support.

With this issue, my colleague is in the process of creating a ticket on behalf of @nmiller & @trooper9698 in order to collect a HAR file to help troubleshoot what you’re seeing. If you already have a ticket number, please share that here.

1 Like