Ping shows real IP address

Hi, just started to learn and use Cloudflare. Hv setup the basic stuff like -
*Adding Cloudflare’s NS record to the registrar and removing the default NS
*Add an A record on Cloudflare for the domain and point its IP to my vps
*Enable DNSSEC
*Enable Full(strict) SSL/TLS
*Setup & create certificate on vps using Letsencrypt

All is working fine-
*I can find my website using the domain name
*Check DNS Record shows Cloudflare’s IP address

But when i ping the domain, it will show my original/vps IP address. Shouldn’t it show Cloudflare’s IP instead? How could i fix it so it will show Cloudflare’s IP?

My domain name is

Thank you very much,

That will be a DNS propagation issue on your end. Simply wait a couple of hours.

The naked domain is properly proxied, however there is no www record, should you require that.

hi, i create the record like 10+ hours, but i did Pause and Enable/Disable the SSL/TLS for the setup just now. I will try to wait a bit longer and check again. But am glad thats an issue and it should show Cloudflare’s IP instead of our own :slight_smile:

Rgd the www, i deliberately left it out for now since im just doing some test and will decide whether to include that in future


Resolves and loads just fine ->

1 Like

yup, it is ok now. thanks a lot :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.