PHP.ini not being recognized, due to A record?


#1

The CloudFlare DNS records show the A record pointing to web host server IP.
However, when I do a dig at https://gwhois.org, the A record actually shows a Cloudflare IP of 104.24.112.249.

This came to light when I had modified the PHP.ini file to add a line for post_max_size but the WordPress plugin isn’t recognizing the change. The web host provider says this is due to the fact that the A record really isn’t point to their server.

Can you shed any light on this? Thank you.


#2

That’s the correct setting for your A record. Visitors will hit Cloudflare’s server, which then pulls data from your own server. So acting as a Reverse Proxy, Cloudflare can provide the security and performance services by “mirroring” your site.

Have you done a phpinfo() to get a readout of your settings?

https://mediatemple.net/community/products/dv/204643880/how-can-i-create-a-phpinfo.php-page