Php file upload script not working after adding website to cloudflare

I subscribed to the pro package of cloudflare 1 day ago. I added the website on cloudflare and now some php functionality is not working.
I tried to upload an image to no avail using the php script I use for uploading files.
Before adding site to cloudflare everything was working fine.

I have also created page rules (with WAF turned off) pointing to my php upload script but still no solution found.

Kindly assist. The website needs to go live in 2 days.

May I know what error code or error message you’ve seen regarding this issue?

I’m getting an error from my php script that no file was sent.

first, check cloudflare event log.
Second, is your upload function using ajax or not
and third, can you show you site (or url to upload dir)

Where do i check for the event logs?

The upload function is using php script on the server. No ajax used.

It’s available for Enterprise member.
Check docs here: https://developers.cloudflare.com/logs/

Well. I’m not an enterprise member.

I found the problem was the name attribute of the file was missing as required on the php script.