PHP curl call receives the requested url has been blocked

Hello,

I just installed setup cloudflare but all my api calls from internal apps are failing with error “The requested url has been blocked. Please contact your administrator.” Also as a client ip i’m seeing a cloudfare ip.

My internal ips are whitelisted, for example a wget request works and i’m not in under attack mode.

What can I do ?

wget works, but curl doesn’t? To check for Cloudflare blocks, those would show up at the bottom of the Firewall page in the Event Log.

It would also help to check your server’s logs as well.

If you have control over your ‘curl’ command, you can also try setting the --connect-to to use the server’s IP address.

Thanks for reply.

I have my whitelist rule like this if ip in list allow - it gives the message specified by me
If i change the rule to bypass browser integrity check - i receive “Please turn JavaScript on and reload the page” , “Why I have to complete a CAPTCHA”

And there’s nothing in your Firewall Event Log?

This topic was automatically closed after 30 days. New replies are no longer allowed.