PHP 8.0 support on Pages build environment

Currently, the build env of Pages only supports PHP 7.3 and 7.4.
The latest version, 8.0, is however not supported.