PHP 7 support

I use different hosting service but using cloudflare dns for ssl service.
My hosting company upgrade PHP 7.4 my host but It’s not change anything my Wordpress website.

When I change my name service to hosting Company’s name service ı can see php 7.4 version but now I change to Cloudflare old version.

What I can do for this?

Sorry my bad English?

Cloudflare has nothing to do with which version of PHP you run on your server. How are you testing your version?

wordpress say your PHP version old
And
I use
phpinfo();

That has to come from your server. Your host should be able to explain how to properly test PHP in your account.

2 Likes

They said “You should change your name server cloudflare to our nameserver”.

You’re certainly welcome to do that. You can also achieve a similar effect by clicking “Pause Cloudflare on Site” from the Overview tab here, lower right corner of that page.

What’s the domain?

1 Like

Thanks for kind answer. I do it for try. Yes PHP version seen correctly.
Now I change name server to cloudflare again and I cannot use FTP and Wordpress seen old php version again.

I dont know what can I do.


wordpress address

You should configure FTP to connect to the IP address of your server. Not the hostname that’s set to :orange:.

I know you said you were using phpinfo() to check the version, but is this through a test.php type of file on your site?
test.php:

<?php
phpinfo();
?>

Yes I use one file for test file but Now I cannot change my file.
I cannot see my testfile.
peditrirutinleri.com/test.php

But I create with file manager in cpanel…

Sorry I will contact my hosting …This is not about cloudflare I think

peditrirutinleri DOT com does not appear to be a valid domain.

Actually I try something for my problem.
Now working

If cloudflare disable phpinfo = php 7.0
Cloudflare enable. Phpinfo =php 5.5…

I dont understand

Could you please send us the link there you read which PHP version it is using?
Just past it here, and when we say, disable CloudFlare, so we can have a look.

I think the request is getting cached and therefor you see an old version.
For example:

You have enabled “Cache everything” and therefor the link you are calling for accessing the phpinfo will deliver an old cached respone to you.

1 Like

http://pediatrirutinleri.com/testsayfasi.php

When I pause and development mode
Php version seen php 5.5

Now I change dns you can see

I can confirm that without Cloudflare, it says PHP 7.0.33, but it’s on HTTP (HTTPS doesn’t work).

1 Like

Ok I saw what @sdayman saw:

:grey:: PHP 7.0.33 (without CloudFlare, just DNS as far as I saw)

Now please turn on DNS/CloudFlare Proxy and let me test/see again.

1 Like

Now I change to Cloudflare.

Yes. Now I see:

:orange:: PHP 5.6.36

But as @sdayman wrote:

the URL changed now from HTTP to HTTPS so the server could (most probably) have a different configuration for HTTP requests as for HTTPS requests and passes HTTPS requests to a PHP 5.6 Handler and HTTP requests to a PHP 7.0 Handler.

So please check your server configuration and make them the same for HTTP and HTTPS

2 Likes

Sorrry. How I can set this option. Is this in cpanel or other config file?

Soryy is noob question

Sorry I dont know your setup. If you use cPanel it should be changeable there, but as I do not use cPanel at all you should ask in a cPanel forum.

Anyway this is not related to CloudFlare. CloudFlare can not change server-settings.

Thanks for kind of answer.