Phantom SSL certificate being used (expiring soon)

Note: I’m on a free plan and I can’t publicly disclose the domain name that this relates to.

So I’ve got a domain, let’s say example.com, and a DNS entry for www.example.com.
I’ve got Universal SSL set up and that’s been working nicely for almost three months now.
When I login to the dashboard, I can see that a new certificate has been provisioned for the next three month period, with an expiry in Feb 2024.
Yet www.example.com isn’t using that certificate, instead it’s serving an old one that’s due to expire in a few days time.

Here are some things I’ve tried:

  • create www2.example.com. That one seems to get the 2024 certificate.
  • turn off proxying. That works, I’m using strict mode SSL so it falls back on to my upstream which has a lets encrypt certificate. But I need proxying
  • turn off proxying, turn off universal SSL, then turn back on universal SSL and proxying. That definitely generated a new certificate, which got applied to www2.example.com, but www.example.com still wants to use the certificate expiring in a few days time.

It feels to me like some part of the automated processes that drive universal SSL have failed and some internal Cloudflare system needs a kick. Am I going to have to pay for an account so I can report a bug?

P.S the certificate that I’m seeing on www.example.com doesn’t show up in the list of certificates on the edge certificates screen.

Thanks for the report. I have escalated this to the team.

1 Like

Hello,

We have created a ticket for you. You can find the ticket via this method.

1 Like

Hi - I’m still having this issue. I’ve since upgraded the Cloudflare account to business tier, raised a second ticket because my first one received no replies, and tried to start a live chat session, but that’s not working. This is getting very urgent now, and it’s completely frustrating to hit dead ends every time I try to resolve it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.