Pfsense and dynamic dns

I don’t know what I’m doing wrong with this configuration, maybe I’m thick headed.

I made an API token for my zone

Then in PFSense I entered the following

Disable: Unchecked
Service Type: Cloudflare
Interface: Wan
Hostname: myhouse
Domainname: myname.com
Cloudflare Proxy: unchecked
Verbose Logging: unchecked
username: [email protected]
password/confirm: mytoken
TTL: blank
Description: blank