Periodically, I Cannot Access Any Website Whose DNS is Run Through Cloudflare

I run my router and devices over and I run all my websites through Cloudflare.

I can still access any website that doesn’t have its DNS hosted by Cloudflare normally over and I can access

But, when trying to access any website with Cloudflare serving its DNS, I’m not blocked in the normal sense of receiving a CAPTCHA; I simply cannot access the site at all, as though it doesn’t exist.

I’ve already contacted support for both my ISP and Cloudflare and they both say they’re not blocking anything and that I’m all clear.

Changing my DNS settings doesn’t do anything, but if I use Tor or a VPN, and can access all websites again.

The block only lasts for about 24 hours and then things return to normal. Obviously something is happening, but what?

I’m having the exact same issue. All sites were loading this morning fine and about noon Central time they just stopped loading.

Maybe it’s some kind of maintenance issue related to the weather then, concerning specific routes? Because if either Cloudflare or our ISPs were intentionally blocking anything, wouldn’t it be permanent? Why would it just be a random and temporary issue?

Reply from Cloudflare support yesterday.

"Thank you for contacting Cloudflare Support. I’m sorry to read that you are experiencing some difficulties here.

We indeed had service degradation in IAH colo between yesterday 1600 and today 0125 UTC, and a fix has been deployed at 2021-01-20 01:24:36 UTC

Sorry for the inconvenience, please let us know if you still have issues."

It’s really weird. It’s happened twice now within the last two weeks. Everything seems to be up and working good today. What’s really strange is that it seems to only affect certain ISP’s. Both times it’s happened I can pull it up over LTE and other ISP’s have no problem pulling them up but for whatever reason our local ISP cannot.

1 Like

This Problems are going now since Months.

Had the exact same Problems myself with using on my Router for DNS

After lot of Problems switched back to google and never had any problems since then.
Would never recommend anyone using for dns resolving after this problems.

See here for more Informations.

I don’t think we’re experiencing the same issue.

I’ve never had any issue with In my case, switching that out had no effect.

The issue @darynkyle and I are having seems to be related to the actual lines and/or our ISP in our areas. In any case, functions just fine; it’s more that we cannot access websites hosting their DNS through the Cloudflare network (which is completely unrelated to running your router or devices through

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.