Peoblmi cf-cache-status: DYNAMIC

Hi I hope all is well ^ _ ^

I use APO but unfortunately it doesn’t seem to work on my site it always appears ‘‘cf-cache-status: DYNAMIC’’

My website https://www.oudmalaki.com/

I can not see any indications for APO running on your site.

I see other headers, that indicates you are not using APO:
image

Please make sure APO is installed and running, then try again. These headers are missing:

Thank you very much for the reply it is active but I don’t understand why it doesn’t work

Now I can see the header. Wasn’t working before, is working now. But due to the “expires” header APO will not cache it and set it so DYNAMIC.

image

As you see the expires header actually is even older then the last-modified header. This will make it expires before it is modified, so it would actually never be cached. Please check what caching Tools/Plugins you are using beside APO and try to disable them, then try again. Cloudflare does normally not set this expires header on its own.

I have disabled Object Cache pro and WProcket but sadly the same problem.

Well, I can not support your application, but somewhere in your setup or any plugin must be set a expires header that is somehow predated and makes the site not cachable.

You can find where it comes from or remove/unset it in your .htaccess like this:

<IfModule mod_headers.c>
    Header unset Expires
</IfModule>

or by setting it to “0”

<IfModule mod_headers.c>
    Header set Expires 0
</IfModule>

Hope that helps. Notice that removing this header could result in unexpected behaviour, just like having him :wink:

Here I have change to 0 as you asked for ^ _ ^

That does not seems to do the trick, please try removing the header completely.

Thank you so much for your time I spoke to my hosting ‘’ Clowdways ‘’ they told me that due to Cloudways Enterprise it is not possible to use APO. I find this answer strange ^ _ ^

Ah well… there is also a Cloudflare way of removing headers if I am informed right:

https://support.cloudflare.com/hc/articles/206652947

This may helps getting rid of the header, even if Cloudways don’t want to :stuck_out_tongue:
Just create a Transform Rule (for Response Header) and configurate it like this:

Report back when done. Let’s see if it does the trick with APO.