Pending nameservers update for more than 40 hours

I have made the process of changing my namservers about 40 hours ago! It is still pending. How can I accelerate this process??


Thank you for asking.

Could you try different Web browser and then click on the button “Check nameservers”? Leave it for few minutes or so. :thinking:

Once success, you’ll receive a notification via your assigned email address for your Cloudflare account that the Website is active, also the same message would be seen on the Cloudflare dashboard.

I can confirm your Website works from my end and it’s resolving both non-www and www. There is a redirection from non-www to www.

DNSSEC is not being used and no error so far.

Domain status code is ok.

I can see by the HTTP headers you’re using Kajabi in the background.

  • x-frame-options: ALLOW-FROM

Furthermore, by the WHOIS the domain nameservers are correctly set.


DNS propagation via DNS online tool looks good too.

Furthermore, if you recently changed your domain nameservers, regular DNS propagation time usually takes up to 24-48 hours to complete.

Otherwise, it might be a DNS cache at your local ISP → try restarting the router.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?


Thank you for reply. Unfortunately, the same problem exists in Chrome, Safari & Incognito mode. Even my custom email redacted doesn’t receive emails, it is just sending.

This domain looks to be active and proxied by Cloudflare. Is it still showing as Pending?

1 Like

I cannot found any MX records for, therefore the A is missing too :thinking:

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Could you please double-check your DNS records at the DNS tab of Cloudflare dashboard for your domain name. May I also suggest taking a look into the below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

Also, take a note and please check in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.) if you’re using or just hostname for POP3/IMAP/SMTP server and write back.

The site works well. My email which is associated to the site doesn’t receive any emails. Also in Cloudflare dashboard, name servers are pending

Thank you for your reply. The mail service provider, which is Zoho, asked me to check only the MX records. He neglected asking me to about the A. How to check the A??

Do you think that I have made something wrong or I have missed something??


Your Nameservers are completely different from the ones that are attached currently.

1 Like

What shall I do??

@mr.m.samier Is the image showing the nameservers correct one? If so, you are required to add those nameservers in the bluehost panel.

I tried, but bluehost tells me to add these records if My nameservers are pointing to them, which is not right??

Do I have to add my MX Records in blue host or Cloudflare?? or in both??

@mr.m.samier Its not MX record, but NS record. You need to update this first for changing nameservers


I’m afraid so. Your NS records are not matching. Check the image you’ve posted above & this:

But, surprisingly, they are using CF NS records. You may required to cross-check at first to solve Pending nameserver issue

These are my name servers inside blue host

Here iare the name servers in Cloudflare

Are thy same??


Isn’t this contrary (the image you’ve posted above?)


Different nameservers :thinking:

May I ask if you’ve used Cloudflare before or using some kind of an integration of Cloudflare for your domain at some point by the 3rd-party service provider like eZoic or some web hosting provider like Bluehost as you stated? Or if Cloudflare was enabled/integrated via their cPanel maybe?

Seems to me you’ve got Cloudflare integrated within BlueHost already.

If you’d like to use Cloudflare individually, you’d have to disable the integration first and talk to the BlueHost support, I guess as it’s stated in the article from below:

Nevertheless, currently I’ve got the correct ones which you’ve shared on a screenshot visible on WHOIS while checking domain nameservers:


From now on, you’re managing your DNS records and settings individually on your Cloudflare account.

Therefore, you’d have to double-check your DNS records if some is missing and configure them at the DNS tab of Cloudflare dashboard for your domain name.

I can see there is an existing A, therefore MX points to zoho as it should, correct?

However, there seems to be some redirection loop issue while visiting your Website.
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.