Pending nameservers update after renewal

Answer these questions to help the Community help you get started.

What is the domain name?
namanarora.me

Have you searched for an answer?
Yes

Please share your search results url:

When you tested your domain, what were the results?
A blank page loads up.

Describe the issue you are having:
I had cloudflare setup for my domain. The domain is with namecheap. My domain had expired but I renewed it within a week of expiry. I can no longer access my domain. Namecheap says all is good, but cloudflare can’t see the dns nameservers update. I’ve set them correctly (nothing has changed on namcheap, just a renewal happened)

What error message or number are you receiving?
Nothing. Just a blank screen.

What steps have you taken to resolve the issue?

  1. Searched the community
  2. Tried reselecting the free plan
  3. Tried changing nameservers on registrar website, but it was already set correctly

Was the site working with SSL prior to adding it to Cloudflare?
Yes, it has been on cloudflare since birth.

What are the steps to reproduce the error:

  1. Visit the domain

Have you tried from another browser and/or incognito mode?
Yes

It has been in the pending nameservers stage for about a week now. Please help!

Your domain is currently not using Cloudflare nameservers and that’s why you got that message. Because of that, Cloudflare has actually dropped your domain and you need to set it up anew.

On the SSL question, just because you are using Cloudflare does not mean the site is secure. Your server needs to be secure and you need to have a valid certificate on your server.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.