Pending nameserver update process stuck when NS has changed

Hi,
Can anyone help me why the Pending Nameserver Update process can’t finish?
We’ve changed the nameservers for vixmo.ai, but it’s been more than 24 hours and it’s still not finished.

As additional information, the nameservers have changed when checked at

~ % nslookup vixmo.ai

For comparison, my friend also registered his domain on Cloudflare an hour after us. But his domain was approved three hours later.

Is there a step I’m missing?

It looks like you’ve just added NS records to your existing DNS.

You need to change the nameservers at your registrar, since they currently point at ns01.trademarkarea.com according to the .ai registry.

4 Likes

Hi KianNh,
Thanks for your reply, but we have changed the Nameserver on the Registrar side from 3 days ago, but it still hasn’t worked until now. The bad news is, on the Registrar side can’t fallback to the default Nameserver because it is still pending to change the Nameserver to Cloudflare (from 3 days ago)

How long does your registrar usually take to change nameservers?

The change not taking effect after 3 days sounds like something is stuck.

1 Like

I’m not sure how long it will take, but from the Documentation it says

“Please note that DNS updates are not done instantly. Servers’ propagation throughout the internet can take between 24 to 72 hours.”

WHOIS says Marcaria is your domain registrar. Marcaria’s WHOIS says you’re not using Cloudflare name servers:

Even WHOIS at nic.ai agrees:

You’re really going to have to push your registrar on this, as Cloudflare can’t do anything until your registrar fixes this.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.