Pending nameserver update more than 2 days

Hello all. i have updated my nameserver 2 days ago and still stuck in same status, i have checked the ns in whois and the update is reflected everywhere in the world.

Greetings,

Thank you for asking.

Interesting :thinking:

May I ask did you added assigned Cloudflare nameservers under your CF account to your domain registrar?

May I ask can you, just in case, double-check if you added them as “private nameservers (NS)” as NS type of the DNS records, or rather as a domain nameserver? :thinking:

All Queries to kanye.ns.cloudfare.com for aldalportal.sa/SOA timed out or failed

ERROR: Some of your DNS servers do not have A records at all. I could not find any A records for the following DNS servers:
kanye.ns.cloudfare.com

You must have A records for all of your nameservers.
FAIL: The following nameservers are listed at your nameservers as nameservers for your domain, but are not listed at the parent nameservers (see RFC2181 5.4.1). You need to make sure that these nameservers are working.If they are not working ok, you may have problems!
kanye.ns.cloudflare.com

ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are:
kanye.ns.cloudfare.com
This is listed as an ERROR because there are some cases where nasty problems can occur (if the TTLs vary from the NS records at the root servers and the NS records point to your own domain, for example).

DIG shows:

;QUESTION
aldalportal.sa. IN NS
;ANSWER
aldalportal.sa. 21600 IN NS fay.ns.cloudflare.com.
aldalportal.sa. 21600 IN NS kanye.ns.cloudflare.com.

WHOIS returns fay and kanye too.

Before changing the domain nameservers, may I ask if you’d know or if you could ask your domain registrar, if the DNSSEC option was disabled and no DS records found at your domain registrar? :thinking:

Furthermore, I can see your website is working, but I guess you’re using unproxied :grey: (DNS-only) A www and/or A aldalportal.sa DNS record? :thinking: Otherwise, you’ve used “Pause Cloudflare for this site” option?

May I ask if there was an option to add an the “Glue IP” for the domain nameservers at your domain registar? :thinking:

Hello,

DNSSEC not enabled and you can check with whois. do you see any configuration issue by querying the DNS? i don’t have much experience with dealing with DNS records but i’m sure i have added the A record in Cloudflare, otherwise, my website will be not working right?

I did not pause the website, and i’m already using proxied mode.

I am giving my best to figure it out to provide some feedback information.
Thank you for patience.

I wouldn’t say because when doing nslookup and dig, I got your origin IP address returned (starting with 158), instead of Cloudflare :orange: proxied :thinking:

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

I have already created a ticket, ticket no : 2514026

1 Like

Thank you.
I am escalating it for you.

Kindly and patiently wait for a reply.

Any updates for my issue? please help.

This post was flagged by the community and is temporarily hidden.

Hello Fritex,
i did not get any useful reply so far. any updates?

Hey there,

Sorry for the delay on this. I’ve replied on the ticket, and that should fix the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.