Pending Nameserver Update For weeks


#1

I have pointed my domain DNS server to cloudflare for weeks. but it status still show as “Pending Nameserver Update” please help me. I am sure I point correctly.


#2

What’s the domain?


#3

I cannot disclose the domain here. You can check it with my email address on my cloudflare forum account.


#4

I’m a customer, so I don’t have access to your account.

What usually happens is you aren’t using only the two name servers Cloudflare assigned to you. For example, if WHOIS looks like this:


#5

My is the first one.


#6

Your nameservers are not pointing to cloudflare. You mentioned you changed the names a while ago, those changes usually happen pretty quickly, if it’s been more than 48 hours, I’d re-connect with your registrar and confirm the change with them.

You can verify the change has taken effect with a dig command -> $dig ns example.com +short, you’ll see something like example1.ns.cloudflare.com and example2.ns.cloudflare.com.


#7

Is more than 48hrs… Still not updated…


#8

https://whois.aliyun.com/ 在此处查询你的域名,例如输入arey.cc,确保Domain Status显示OK与Name Server正确


#9

According to @cloonan, you didn’t update your name servers at your registrar. Have you done that?
As you can’t disclose your domain name, you’re better off opening a support ticket where they can look at your account. Email them at: support AT cloudflare DOT com


#10

Waiting reply. :slight_smile: I have also send email to [email protected]


#11

Hi @Jimmys, couple of things:

  1. The contact you need to make is your registrar to update your nameservers, not to support at Cloudflare. If you’ve previously updated your name servers with your registrar, you need to contact them and ask why the change is not effective. You can monitor the change using this command: $ dig ns example.com +short Replace example.com with your domain. You’ll get a result that matches the nameservers Cloudflare shows on your DNS tab. Now, you’re getting something like:

$ dig ns example.com +short
ns01.name.com.
ns02.name.com.
ns03.name.com.

  1. The way to contact Support at cloudflare is via email to Support (not contact): support AT cloudflare DOT com

#12

Your nameservers are still not updated. THis change needs to be made at your registrar (the place where you purchased your domain name). Your nameservers are currently set to:

example.com.|14399|IN|NS|ns05.usonyx.net.|
example.com.|14399|IN|NS|ns06.usonyx.net.|
example.com.|14399|IN|NS|ns10.usonyx.net.|


#13

My domain is from namecheap. I can confirm I have updated the DNS to cloudflare via my namecheap account management… but it still showing as pending update… what is going on?


#14

You can check name server propagation at:
https://www.whatsmydns.net (make sure you select NS for your domain).

It should have only the two name servers Cloudflare assigned to you. Once that’s done, it takes an hour or two for Cloudflare to re-check. I think you can even click a Re-check button on that domain setup page.


#15

When I do a whois lookup the registrar is listed as ADICIO PTE LTD. That could be who namecheap partners with to provide the domain. I would recommend contacting them because the value is not being propagated/ reflected to the internet.