PDF viewer errors after being proxied (ad1023ff)

Is there anyone having a problem with PDF.js viewer with Open Journal System (OJS) after being proxied? The error message: "PDF.js v1.8.188 (build: ad1023ff) Unexpected server response (0) while retrieving PDF.

The website is normal; it just cannot retrieve the PDF.

I use it as a “standalone app” on few websites.

I am not familiar with this one.
Does it use iFrame or?

Within the same domain, or trying to open PDF from like Google Drive, etc.? (Cross-origin issue maybe)
Nevertheless, have you tried checking out if for example, Rocket Loader conflicts with some script (but I doubt).

1 Like

Hi, yes, the OJS uses iframe within the same domain. It’s not only unable to retrieve PDF but download as well after being proxied.

Thank you for the suggestions.

Maybe if you try to add HTTP headers just in case:

May I also ask if this happens only to you or even tested with multiple different users?

  • some issues if using Internet Download Manager so far …

May I ask if you have got the x-frame-options HTTP header set to DENY or something?

Can you share an URL of the example so we might try to open it and provide more feedback?

1 Like

Hi, the suggestions above have been tried with CORS or x-frame. Thank you. We are now back to DNS only rather than Orange cloud. I can’t give you the URL for now as the error will pop up after the proxy is set.

Thank you :pray:

May I ask just in case, do you see any blocked requests under the Firewall → Firewall Events tab at Cloudflare dashboard when you open your URL address?

Furthermore, before moving to Cloudflare, was your Website working over HTTPS connection?
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

It may also be something in between as HTTP or HTTPS, either non-www or www redirection and cookies, if so.

You might also want to re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

As you cannot share the URL, I can only guess.
Otherwise, kindly try to debug this erro at the origin host/server and review your Cloudflare setup for your domain name.

Check also as follows on the below link:

From my first post including suggestions what for to look up, and this one, I am afraid I cannot provide any other useful information or help for further.

Dear fritex,

Thank you for the feedback. Yes, there are firewall events in the cloudfare dashboard.

SSL uses full strict mode, with https. But we may have a problem with www and non-www. The domain was firstly registered with non-www.

I somehow redirect non-www to www in .htaccess

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.