Payment method error (Code: 1201)

I can’t add a new payment method, I get this message:
There is an issue with the payment information entered. Review and try again. (Code: 1201)

If you’ve reviewed and tried again…then waited a while and tried yet again (it may be temporary), open a ticket for Billing:

To contact Cloudflare Customer Support, login & go to and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

I’m having the same issue, it seems that they dont want the deal…

I have the same problem, I get the same error and I cannot pay
What happens?
Thank you

I am getting the same issue.

Hello. I am trying to add Credit Card into Cloudflare but it’s not working.

I have tried 3 different credit card from three different credit card company but none of them are working.

Error: There was an error processing your card. Please check your details and try again.


Hi @optimizefreak,

@sdayman’s response earlier in the thread applies here too. Please try again now and if you still can’t, you will need to contact support.

1 Like

I am facing the same issue, even more I tried paying with paypal and the payment was declined, I have been paying with my credit card in the internet for over 3 years and with my paypal for over 8 years, I never faced such problem, I contacted the support but their reply was a general reply about payment validation method.

Is this still an ongoing issue? Have you reached out to the Billing team?

1 Like

Hi there,

My name is Zein, a Product Specialist here at Cloudflare.

We’re sorry to read that you’re experiencing difficulties.

Is this still an ongoing issue? I have checked internally and a Billing Engineer reviewed your account and it shows that your credit card was successfully added to your account.

1 Like

I solved the payment issue, but I had another one , one of the US servers weren’t working for my users, I contacted cloudflare support many times,it was never solved and no one gave me an answer, for that reason I removed cloudflare from my domain.

A post was merged into an existing topic: The card is not added

@zein I’m having the same issue today. Tried with 2 cards, error 1201.