Payment gateway SecurePay needs to be IPv4


We’re trying to move all our DNS records to Cloud Flare however have run into an issue because our payment gateway SecurePay doesn’t use IPV6. It is in part related to this issue however SecurePay have said their platform has changed since then.

Basically about half of our transactions were failing because of an Invalid IP address.

I have tried to get help from SecurePay on this but am at a bit of a loss on what settings need to be changed.

SecurePay have advised that it needs to be IPv4 - I tried Add Header in Pseudo IPv4 setting but this did not fix the issue.

The last correspondence SecurePay provided was this:

Please be advised that our level 2 team has suggested that your payments have been passing through an invalid IP address which we do not support .(Please find more information in the XML API guide URL : - in Page 19)

Any assistance would be greatly appreciated.


Are you talking about software which runs on your server or about a third party service which connects to you and which does not support IPv6?

It’s a third party service - SecurePay is a payment gateway like Stripe, Braintree etc - it does not support IPv6 for payments made through our website using their payment gateway.

In that case you should ask them why they resolve and connect to AAAA records. If they do not support IPv6 they should only query for A records.

On the free plan you cannot disable IPv6 I am afraid.

Thanks Sandro, does the Pro plan allow you disable IPv6?

It should,

Though confirm it with support too before upgrading, as that has changed a few times recently.

Ok thanks - I thought I had read something in the community that said IPv6 can’t be disabled but now can’t find the article.

Previously you could disable it but only via the API, not the dashboard. Now it seems they removed that for Free plans altogether and only Enterprise plans can disable it via the dashboard, the others have to go through the API.

Ok thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.