Paused CF for a zone, HTTPS DNS records still says h3

We paused Cloudflare for a zone but any DNS record that’s still set to proxy has an HTTPS record that still says “alpn=h3,h2 ipv4hint=…” – the origin server doesn’t support HTTP3 though.

DNS records that aren’t set to proxy don’t have an HTTPS record.


1 Like

Yes, you’re correct and I’d consider it a bug and have reported it via escalation.

As a workaround, shutting off the proxy for a host will work as expected, rather than doing “pause cloudflare”.

1 Like

Hi there,
Thanks for reaching out on community!
We would like to ask you a few questions.

  1. What is your domain?
  2. What is your expected result?

Because Cloudflare will do HTTP/3 to customers’ eyeball but forward request http1.1 or http2 to the origin.
Also, I assume the protocol optimisation was configured to http/2 and http/3 by you at Cloudflare.
Have you changed so?
When I turn on HTTP/2 and HTTP/3, my alpn change to those protocol.

This is when “Pause Cloudflare” is in effect and requests are going directly to the origin.

1 Like

Hi Team, @i40west and @rolmos,

Any one of you able to raise a ticket for me to link an Engineering case to it?

I agree with @i40west and this may be a confusing behaviour, but will leave it to Engineering to respond if it is unexpected.

Thank you.

Sure. Ticket #2896477.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.