Passive listeners to improve scrolling performance

Friends good night.
How do I resolve this issue?
Is there anything I can do for CloudFlare?


Rocket Loader pulls existing JavaScript from your site and then bundles it. Whatever .js warnings you see in RocketLoader have to be traced back to the source on your site.

I get these warnings also, but it’s really not an issue on my page performance.

If you really want to pursue this, you’ll have to disable Rocket Loader in Speed → Optimization and then see where it’s really coming from.

If I disable Rocket Loader, could I have a problem?

No. I don’t use Rocket Loader and find my site is already optimized enough to not need it.


I turned it off and then cleared the cache. Did not work. The most errors appeared.

Do you have another option?

Another thing. This error only appears on the website’s homepage.

What do you mean “did not work”? Those warnings aren’t going to go away. They were just routed through Rocket Loader. You need to track them down.

1 Like

When I disabled Rocket, other errors appeared.

I will use your information and pass it on to the developer.
Thank you very much for the clarifications.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

How do I solve this problem?
Does not use passive listeners to improve scrolling performance

Consider marking your touch and wheel event listeners as passive to improve your page’s scroll performance. Learn more.



I looked here in the community and didn’t find an answer.

The best answer I found was that I can disable the rocket. The problem is that the domain has some subdomains and that would disable it for everyone.

Are there any rules I can apply?

Thank you.

You can create a Page Rule for either or (which ever is your canonical hostname).

1 Like

I had forgot that I opened this topic with similar name.
We are working and testing.
Thaks yoyu.

1 Like