PageSpeed peformance loading time problem after adding cloudflare setting

MAIN PROBLEMS

  1. The site is too slow to access.
  2. Loading time problem on PageSpeed site and display errors
  3. Share the post links on social media display access denied DomainName Cloudflare restricted to access

I have got the loading time problem on PageSpeedTesting and GTMetrix after adding the Cloudflare settings. Also and if you share the post links on social media the link will not display the content and thumbnail of that post and if you will try to change some settings on DNS the link will display access denied YourDomainName Cloudflare restrict access. And another issue the site now becomes too slow when you access it.

I will share my DNS screenshot if there is any mistake you can help me. Or if there any way to solve these problems I hope you will help me a lot

This is my site connected to CloudFlare

1 Like

That site is not using Cloudflare. As you can’t :orange: Proxy a wildcard DNS entry, and your ‘www’ redirects to the apex domain, you’re going direct to server.

Furthermore, you’re using Ezoic, so they control the performance of your website. You need to work this out with them.

2 Likes

So what is supposed to do here? Is to remove the Ezoice Account or to disable Ezoic performance only.

Secondly there something needs to be changed on the DNS setting or the issue is to remove the redirect to the apex domain

Give a try to cloudflare APO and use wp rocket and optimise images to speed up if you are using wordpress. Further you even use cloudflare argo smart routing

I disabled the Ezoic performance and PageSpeed test scan my site with no error but on Gtmetrix the problem still continues

Is there any method to apply as you said! Because you will need to purchases this service

If you are using wordpress then there is a plugin.

In that for caching, use workers. Note that workers has limits. Also for wp rocket you can take look at GPL plugin make sure you antivirus test before use it or go with free plugin. If not try fast CGI caching

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.